
Using WSJT-X for JT4 EME Operation 

Updated to WSJT-X r5604

document  revision 6

G3WDG
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Program Download from:   

https://drive.google.com/file/d/0B116IwQIUFNTV1NIRnpZeHY3a2s/view?usp=sharing



Features in WSJT-X JT4

• Enhanced sensitivity  decoder (single period decodes and correlation averaging)

• Doppler control (“full” and “constant freq off moon” modes), compatible with a 
wide range of radios.

• Doppler calculations have changed,  resulting in much  improved accuracy.

• Averaging now done automatically, no need (or ability) to select frames to be 
excluded in the average. 

• Simpler switching between single tone and long form messages

• Wider dynamic range for signal reports, no more limiting at -10/-11  for strong 
signals and with good accuracy of dB level differences, and reasonable agreement 
with link budget calculations.

• Echo mode with Doppler correction
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Differences to WSJT10 - 1

• There is no longer a DF parameter, instead a Freq term is used

• Freq is now defined as audio frequency of lowest tone

• No longer any reference to 1270Hz

• For all sub-modes (A-G), lowest tone is at 1000Hz.  Subsequent tone spacing 
is same as for WSJT10. For example, for JT4F the tones are now at 1000,  
1158,  1316 and  1474Hz.

• Rate in and Rate out are gone.  Audio sampling has to be done at 48kHz!
(see Section 3.1   of WSJT-X manual).  

• Other setups are done differently to WSJT10  – (refer to WSJT-X manual and 
later pages here).

• MinW setting can be set to A, with  no need to adjust for different spreading
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Differences to WSJT10 - 2

• Single tone frequencies are now:
1000Hz: tuning in tone 
1250Hz:  please send messages 
1500Hz: RRR 
1750Hz: 73
(Single tones are still  “decoded” by eye.)

• Files such as all.txt, .ini file and the folder SAVE (for wav files) are in a 
different folder, example:  C:\Users\<user name>\AppData\Local\WSJT-X  .  
Note on some PCs, AppData may be a “hidden” folder. The path on your 
PC  can be deduced  by looking in File->Settings->Audio 

<user name>  above is current user name
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Differences to WSJT10 - 3
• Waterfall and average spectrum combined in one window called Wide 

Graph

• Average spectrum has letters corresponding to meaning of the single 
tones for easier identification by eye,   which move to correct 
positions based on clicking the 1000 tuning tone from other station. 

• RF power control from the main window 

and Tune facility (1000Hz tone) 

T= tuning in  tone
M= send messages
R= RRR
73=73

• Yellow average spectrum 

develops during the receive 

period, instead of appearing at 

the end
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Differences to WSJT10 – 4 
Meaning of the characters after decodes: 

1755 -13 2.62 1190# G3WDG OK1KIR -15       * D

* Indicates convolutional decode, or number here means correlation 
decode and number indicates confidence level

Decoder bin width  used, 
(as in WSJT10)

1809 -13 2.27 1238* G3WDG OK1KIR JN79      * D  3

A number here means decode was from averaging and 
number indicates the number of periods used in the average
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Differences to WSJT10 – 5

Nominal DT = 0 if unticked
Nominal DT = 2.5 if ticked

DT Tolerance, +/-
number selected

Replaces Tol box in WSJT10

Narrower tolerances seem to make little improvement, better to select on the wide side especially if signals are 
not marginal.

Note:  If EME is not ticked, for terrestrial use, PC clock accuracy should be within +/- 0.35 sec
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What hardware do you need for WSJT-X?

• SSB transceiver and antenna

• Computer running Windows (XP or later), Linux, or OS X

• 1.5 GHz or faster CPU and 100 MB of available memory

• Monitor with at least 1024 x 780 resolution

• Computer-to-radio interface using a serial port for T/R switching, or CAT control, or VOX, as required for your 
radio-to-computer connections

• Audio input and output devices supported by the operating system and capable of 48 kHz sample rate

• Audio or equivalent USB connections between transceiver and computer

• A means for synchronizing the computer clock to UTC within ±1 second  (but see page 9 ) 

• Radios without CAT control can be used if other end does full Doppler correction. 
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Setting up for Microwave EME and  Doppler Control

• The following pages describe how to set up and use Doppler control

• It is recommended to follow the steps in the sequence shown in the 
following pages

• The examples shown are for the 10GHz band
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Files->Setup->General

x
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Doppler control – pre setup

• If previous versions of WSJT-X (prior to r5260)  have been installed, it 
is necessary to delete the WSJT-X.ini file before installing new version 
of WSJT-X (see page 4 for location of this file)

• For each band, it is necessary to enter an “offset”.  Offset is defined as 
(desired radio’s frequency – operating frequency).  For example, for 
10368 and a 144MHz radio it is (144-10368) = -10224.  If a 28MHz 
radio is used, with a 28/144 transverter prior to the 144/10368 
transverter then the offset is -10340. 

• Set to JT4 mode in main window
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Setting JT4 Modes

Changes sub-modeShows selected mode
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Changes decoder bin width.  Can 

safely be set to A independent of 

signal spreading.



Setting the offset 
From File->Settings->Frequencies follow these steps:

1. Press RESET and answer YES

2. Right click in Station Information area and select insert

3. Select band from pull down and type in offset

4. Press OK

5. Press OK to close Frequencies window 

Go to main window

• Select 3cm (pulldown)

• Frequency display should now read 10,368.000 000

To edit an existing offset in the Station Information area, double left click the offset number and retype the whole new 

offset number, and press OK. It may sometimes  be necessary to re-select the band eg 3cm on main window to make 

the change in offset take effect.
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Doppler setup – setting the radio

• Determine which methods will be used for CAT control and PTT,  and  
which COM ports are used for each, eg use Windows device manager 
to identify which serial ports are which.

• Plug in the interfaces and connect to radio

• Fill out the other settings as appropriate for the radio and interfaces, 
referring to radio operating manual and/or the internet as needed

• Press Test CAT and Test PTT

• In case of Rig Control errors………. experiment.    If the radio will 
support it, use of higher baud rate may be beneficial to reduce rig 
control errors.
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Setting the radio (IC735) With this configuration, the 

IC735, which can have its 

frequency controlled when on 

TX,  is not operated in its own 

Split mode, just uses VFO A.

Experience will be gained with 

use of more radios of different 

models  enabling better 

recommendations to be made

including whether to use Rig or 

fake it. Some experimentation 

may be needed here.

Radios tested to date for Doppler control: 

IC735 (G3WDG) 

IC910H (VK7MO) 

TS2000 with upgrade  (K1JT)

FT817 – (G4FRE/OK2AQ) does not work

K3 – (G4FRE)

KX3 – (G4FRE)
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Setting the radio (FT847) 
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FT847 radio is operated 

in split mode

Tnx OK2AQ



Setting the radio (IC910)
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Tnx VK7MO



Setting the radio (K3/KX3)
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Tnx HB9Q



Radio settings for one com port 19

Only works with  CAT  interface that has external power



Setting the radio – non CAT transceiver 20



Doppler control modes (ASTRO window)

Mode when both stations  running WSJT-X
or for self echo testing. Advantage of this is 
that other stations can monitor a QSO if  
they know the sked frequency as Doppler 
shifts  are corrected by each station 
individually, giving a “constant frequency on 
the moon”.

Mode when one station is doing Doppler 
tracking for both stations.  Other station 
receives and transmits on the sked
frequency with no Doppler corrections.

Set sked frequency, in this case 10368.200

Note: It has been suggested that ‘Constant frequency 

on Moon’ operation is at 200kHz above band edge and 

‘Full Doppler to DX Grid’ operation is at 225kHz.

Used to trim radio tuning, in 100Hz steps, to 
accommodate a station who is more than a 
few hundred Hz off frequency
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Doppler example 22

Total (two way) Doppler shift of your own echoes (Hz)

Total Doppler shift between you and  DX station (Hz)

In Full Doppler to DX Grid mode,   DX station operates on the sked

frequency with no correction on tx or rx. Your rig is tuned + and –

by the DXDop figure,  so you hear the DX  station on the corrected 

frequency and DX station also hears you on the corrected 

frequency.  In this example, you would be transmitting on 225-

4.431=220.569kHz, and receiving on 225+4.431=229.431kHz. 

In Constant frequency on Moon mode, both stations offset their own   

one-way Doppler shift (in example shown this would be -11246/2,  ie

-5.623kHz), in one direction on tx and the other direction on rx. In this 

example, you would be transmitting on 225+5.623=230.623 and 

receiving on 225-5.623=219.377.  [In essence, this is similar to CW 

operating procedure, where one station nets their own echoes on the frequency 

that they are receiving the other station and both stations copy each other and 

their own echoes].

Another station can also monitor the QSO if they know only the sked

frequency, if also operating in Constant Frequency on the Moon mode.



VK7MO’s Recommended settings for Wide Graph

Setting of N Avg affects waterfall speed

Setting of  Bins/Pixel affects span of 

displayed audio spectrum Waterfall gain Waterfall zero

Spectrum gain Spectrum zero

Spectrum smoothing
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Some experimentation with palette, gain and zero settings 

is recommended to match operator preference. Some 

weak signal files to help optimize settings are available at:

http://www.sucklingfamily.free-online.co.uk/REXFILES.zip

More info at :  http://www.sucklingfamily.free-online.co.uk/Waterfalls%20on%20WSJT10%20and%20WSJT.docx



Using the frequency spinners in ASTRO window

• Two “spinner” controls are provided to allow radio frequency to be set above the 
band edge, in kHz (1kHz steps) and Hz (100Hz steps). The frequency above band edge  
is the sum of these two controls (ie kHz + Hz).

• It is recommended that skeds are arranged to be on exact multiples of 1kHz eg 200, 
225 etc, so the Hz spinner  should normally be set to 0 to avoid unwanted offsets.  Any 
offset entered here will return to zero when the program is closed and  restarted.

• The  two controls can also be used to tune the radio in real time, for example to 
accommodate a station who is not exactly on frequency, or to find a station who has 
been detected on another frequency  eg seen on a separate  SDR.  Doppler 
compensation is maintained while the radio is being tuned with the spinners.  

• When using for fine tuning, decrease frequency to increase tone pitch.
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Audio levels

The only remaining thing would appear to be level settings. The orange level indicator on the left hand side of the WSJT-X main window is your 
friend here. I would recommend setting the gain slider next to it about half way for a start. Then adjust any Windows microphone level for the 
device you have connected to your receiver to maximum. It is worth checking at this stage that you have disabled any special effects on the 
microphone device such as echo cancellation or boost. Then you need to adjust the audio out level with either the output gain control of the 
rig or the interface. Aim to get the orange indicator falling just short of maximum for strong signals. If that doesn't get you a reasonable level 
and the indication is too high then try adjusting the Windows microphone level down. If that leaves you with too low or too high a level; adjust 
the gain slider in WSJT-X to compensate.

If you find that the gain slider in WSJT-X is near the top or bottom then you are probably under driving or over driving the sound card input 
which is not desirable and you need to investigate adjusting the audio level before it gets to the sound card.

This material copied from WSJT User Group posting.

WDG note: I input the same audio level as gave 0dB on WSJT10, then adjust the slider to get noise at about 30.
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PC volume control settings (WDG Vista PC)
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Audio settings in –X (WDG specific)

These are for mic input jack and headphones jack
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Setting decoding type

Note: Averaging is also  in operation with this setting at present
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Entering DX station info 29

1
.

Lookup or add if station not in database

2

press

If Generate Std Msgs is not pressed it is 

possible to have wrong callsign in messages!



General settings for “long form” messages

Note: decoded messages appear in red when they contain your call
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General settings for “single tone” messages 31



Click decoded message to set report automatically 32

Double LEFT click message 

sends report to TX box 2 or 3

as appropriate



Examples of single tone messages

Tuning-in tone  (1000Hz)

Please send messages  (1250Hz)

RRR  (1500Hz)

73  (1750Hz)

Note: Single tone messages are decoded by eye from the yellow average graph.

Do not use the red markers at the top of the waterfall (these mark the expected 

positions of the JT4 message tones),
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Determining tone frequency from wide graph
34

Place cursor on top of 

yellow peak and click

Read frequency from main window



Calibrating a CAT non GPS locked  radio
1. Inject a signal at IF eg 28 or 144MHz,  1000Hz  above the set sked frequency. 

Ensuring Doppler compensation is set to “None”, measure the frequency of the 
tone as described on the previous page

2. Go to File->Settings->Frequencies and enter  any difference from 1000Hz into 
the Intercept field in the  Frequency Calibration. Slope stays at 0.
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Example 1: If the tone is seen at 1125Hz, set intercept to (1125 - 1000) = 125.

Example 2: If the tone is seen at 975Hz, set intercept to (975 – 1000) = -25

Calibration correction takes place after the Frequencies window is closed.



Erasing message windows

Left click once to erase Average Decodes

Double left  click to erase Single-Period Decodes
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Power adjustment
37

Power slider can be used to adjust TX power. 

Provided that the system is linear, changing 

the digital gain by a given number of  dB will 

change RF output power by the same number 

of dB.

Control range is 0 to -45dB

[Hover mouse over the slider knob to read the 

digital gain.]



Inactive buttons at 432MHz and up
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Operating guide (WSJT-X to WSJT-X)

• Set sked frequency above band edge in Astro Window.

• If you are second station, left click on 1000Hz tuning signal from first station which transfers exact 
frequency to Rx box.  Can click on waterfall trace or yellow spectrum peak. To start transmitting 
press Enable TX button. 

• If you need to correct only your  RX frequency later eg to accommodate a slightly drifting station, 
left click on their 1000Hz tuning-in tone or their  lowest JT4  tone on the waterfall or yellow 
spectrum peak.

• Tick Sh to switch from long form messages  to single tones,  if desired. With ‘Sh’ ticked,  ‘Tx6’ tick 
box switches TX6 message box from 1000Hz (Tune) to 1250Hz (Send Msgs). 

Several EME  tests using WSJT-X at both stations  have been successful.  Details are posted here:

http://www.sucklingfamily.free-online.co.uk/WSJTXtwowaytest.pdf

http://www.sucklingfamily.free-online.co.uk/ok2aqg3wdg.pdf
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JT4F Operating guide (WSJT-X to other station using  WSJT10)

• Set sked frequency above band edge in Astro Window.

• Edit your tuning-in tone freq to 1270Hz  by typing @1270 in TX6 message box

• Tick Sh to switch from long form messages  to single tones if needed. 

• Some single tone freqs now slightly different to WSJT10 - not an issue

• If you need to correct only your RX frequency eg to accommodate a slightly  off-
freq station,  left click on the lowest JT4  tone from the other station, to change 
only your RX freq.  Do not click on their 1270 tone, or it will offset your Rx Freq, 
as WSJT-X expects the tuning tone to be at 1000Hz.

• Tick Sh to switch from long form messages  to single tones,  if desired. The single 
tone messages transmitted by WSJT-X are in some cases slightly different to 
WSJT10 but not enough to cause any confusion..
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Self echo testing

• Select ‘Constant frequency on Moon’ from Astro window

• Set sked frequency above band edge in Astro Window.

• Start a transmission of a single tone or other signal  using “Tune” button, 
then press “Tune” again after about 3 seconds.  

• Echo should appear on waterfall and yellow average graph  at 1000Hz. 

• Use PC’s Print Screen facility quickly to save it if wanted,  before traces 
disappear!
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Examples of single self echoes

10368MHz with 3m dish at different power levels – spread ~100Hz. 

1000Hz tones  and JT4F

2W

3W

100W

100W JT4F
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Using a simple non CAT radio eg IC202

• Other station  does full 
Doppler correction

• Tune in their 1000 tuning 
tone  to 1000 on 
Widegraph as closely as 
poss

• RIT should be set to OFF or 
in zero position and not 
adjusted

May  get rig control  error if this is 

ticked!

43



Random notes - 1 
• Audio level on TX may differ from WSJT10 and volume controls may 

need to be readjusted. For RX, use the  same input  audio level as 
previously used with WSJT10,  and adjust slider to have audio at 
about 30 on the scale

• Remember to press button next to Tx Box to engage any changes to 
message in that box for immediate transmission.

• Observe that message box  is sending is what you expect and if not 
press 

Normal message

Single tone message

Free text message

Note: a Free Text message appears  in colour in TX text 

box.  Free text messages require stronger signals to 

decode compared to normal messages.
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Random Notes - 2

• As installed, WSJT-X does not come with a CALL3.TXT file, but will 
generate one automatically if Calls and grids are added with the 
“Add” button.

• Copying CALL3.TXT from a previous installation of WSJT10 can 
sometimes  lead to degraded decoding of very weak signals and is not 
recommended.
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Sample files
Some sample files to play with are located at 

https://drive.google.com/file/d/0B116IwQIUFNTVkxvTThGb0dVV1E/view?usp=sharing

These files were received by G3WDG from VK7MO operating on 24GHz in PF88 with JT4F.  The signals are marginal 
and not all periods will decode.

After downloading the files, unzip and copy them to the SAVE folder (see page 4 where to find this in WSJT-X).

Suggested initial  settings for these recordings  are MinW A, RX 1100, Ftol 100, Sync 0 and DT Tol 0.5.

You will need (temporarily ) to set your call in Files->Settings->General to G3WDG (please remember to put it back 
to yours afterwards!). Enter VK7MO as DX Call and PF88 as DX Grid.  Files are loaded using File->Open, clicking on 
the first one and then click Open. Files can then be replayed one at a time with F6 or all together using Shift F6.

Try the effects of varying the settings.  Remember to Erase the message windows,  and Clear Average after each 
run. 

The …….2304 period was Rex’s 1270Hz tone, which can be just seen on the waterfall, but clearly seen in the 
Average spectrum (with correct settings).  All  others are messages.  

A second set of files is available at http://www.sucklingfamily.free-online.co.uk/averagingtest.zip. These files are 
very weak, just within the capability of WSJT10 to decode using averaging. 
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Averaging example files decoded

2304 period showing 

VK7MO’s tuning tone
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Echo Mode overview

Echo mode transmits and receives repeated tones. The echo is displayed in the Echo Graph window, 
which builds up  the echoes over time enabling weak echoes to be detected.  Individual echo results 
also appear in a  text window. N=number of echoes averaged, DF=freq offset from 1000Hz (only 
accurate for stronger signals).

Doppler correction mode ‘Constant Frequency on Moon’ needs to be selected to use this mode.

Echo sequences are started by pressing ‘Enable TX button’ and terminated by pressing the same 
button again.

Echo Graph has similar gain, zero and smoothing controls to Widegraph.  Bins/pixel is used to adjust 
the width of the displayed spectrum.

At any point, Echo Graph can be reset by pressing the ‘Clear Average’ button, which takes effect on 
the next receive period.  The text window can be cleared by left click on  ‘Erase’ button.

Windows should be sized and arranged so that Echo Graph is not behind any other window.

Attempts to detect marginal echoes are best done with low libration spreading (“Width” parameter 
in Astro window)
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Method of operation of Echo Mode

When you start Echo mode the program goes into a repeated 6-second 
cycle as follows:

- transmit a 1500 Hz tone for 2.3 s

- reset the dial frequency to account for EME Doppler shift

- receive the echo about 2.5 s later

- compute spectrum of received signal

- plot spectrum on expanded scale, centred at 1500 Hz
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If a program crash occurs with Echo mode the first time it is used try  editing  WSJT-X.ini file,  to change 
EchoBPP=0 to EchoBPP=1 This can be  found in the settings for [EchoGraph]



Echo Mode – 3m dish 10GHz 100W G3WDG 50

Calculated S/N in 2500kHz bandwidth = -2dB N=35 Spreading = 110Hz



Echo Mode – 3m dish 10GHz 1W G3WDG
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Calculated S/N in 2500kHz bandwidth = -22dB  N=51 Spreading = 75Hz



Echo Mode – 3m dish 10GHz 400mW G3WDG
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Calculated S/N in 2500kHz bandwidth =  -26dB N=51 Spreading = 50Hz



Echo Mode – 76cm dish 10GHz 50W VK7MO
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Calculated S/N in 2500kHz bandwidth = -27dB 

N=33 Spreading = 9Hz N=165 Spreading = 35Hz



Decode success and false decodes – F Tol
VK7MO has investigated the occurrence and nature of false decodes at marginal signal levels,  and also 

the effect of different Ftol settings on sensitivity,  using computer to computer tests.  The transmit signal 

used the following parameters:  degradation -22.5 dB and 200 Hz spreading.  On receive, fixed 

parameters were MinW=A, Sync=0, DT Tol = 2 Seconds. The decoder was set to “Include correlation”, 

but this is thought to function the same as “Deep” currently.  A total of 3150  periods were analysed, with 

Ftol set to 10, 20, 50, 100, 200 and 500Hz.

X=2

Y=0.2



Decode success and false decodes – F Tol

• % decoding success range  with Ftol of 500 to 10Hz  of  23.4% and 33.3% represents only about 0.05 dB 
so Ftol is  not all that critical

• If only  periods with confidence of >2 are used  there are no false decodes, but 25% of good decodes 
would be missed.

• False decodes that could be misinterpreted were with calls and reports of  -16, -16, -21 and -18. The 
others were either junk text or otherwise easily identified as false.

Conclusions:

1. There is little penalty using Ftol of 100Hz , or even wider,  in decoding success or 

likelihood of false decodes and offers greater tolerance to frequency offsets.

2. Care needs to be taken in interpreting decodes from marginal signals with confidence of 2 

or less, such as waiting for another decode to confirm.



Decode success and false decodes – DT Tol

The same signal  files have been used to study the effect of the DT Tol setting, using Ftol=100Hz with the 
following results:

The loss in decoding  sensitivity going from 0.3 to 3 sec amounts to only 0.01dB, so use of wide DT Tol is 

considered  OK 



Effect of MinW

DT Tol = 1 sec, Sync=0, F Tol 100 Hz  Test Signal -22.5 dB with 200 Hz 

spreading 

Conclusion: No penalty in using  MinW=A.  Time to decode increases for wider signals, as 

expected.



Effect of Sync Setting
DT Tol = 1 sec, minW=A, F Tol 100 Hz  Test Signal -22.5 dB with 200 Hz 

spreading 

Conclusions: Number of correct decodes reduces with increasing Sync setting. While % of false 

decodes  decreases with increasing Sync setting,  the % of false decodes relative to number of 

decodes is essentially constant.  Thus increasing sync setting uses more sked time to get a correct 

decode and is of no benefit.                               Recommend therefore to use Sync=0. 



Receiving DL0SHF 10GHz JT4G EME beacon

Note the DT at about 

3.25s  – this is normal 

for DL0SHF
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JT4G (for DL0SHF)

When finished listening to the beacon and moving on to other tests, suggest to reset to JT4F!



Compiling WSJT-X in Windows (to get the latest version) - 1

Download and install in this order:
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http://sourceforge.net/projects/jtsdk/files/win32/2.0.0/base/contrib/vcredist_x86.exe/download

http://sourceforge.net/projects/jtsdk/files/win32/2.0.0/base/contrib/OmniRig.zip/download

and download the two files: JTSDK-2.0.0-win32.exe and JTSDK-2.0.0-u1-win32.exe

Then install the first one (this will likely need to be done using “Run as 

Administrator”).  One this is installed, install the second one (which is an update). 

The files should install themselves into C:\JTSDK.

Then update the JTSDK as follows:

Windows Start Button --> All Programs  JTSDK --> Update JTSDK 

Type  update then when that is finished upgrade.

Go to: http://sourceforge.net/projects/jtsdk/files/win32/2.0.0/

Note: Some of these operations can take a long time and one of the files is a large download!



Compiling WSJT-X in Windows (to get the latest version) - 2
To do the build, open up JTSDK-QT which should have a desktop icon. The first time that you 

attempt to build WSJT-X, you will be asked to “Checkout”.  Just follow the instruction in the 

JTSDK window. This only needs to be done the first time, and not for subsequent builds.

Build commands:  

Either  build-wsjtx rinstall

This creates wsjtx\install\Release.    You can copy the files in that directory to another location 

or machine.  Normally you only need the wsjtx.exe executable (need to try this).

Or        build-wsjtx package

This creates an installable for you,  which is overkill if you're constantly updating. The output 

location is displayed on the screen after building.

Each build updates or overwrites any previous one automatically. If you answer "Y" to 

updating from SVN it will update the source directory to whatever was the latest commit by the 

team. If you say 'N', it will build whatever is already  in C:\JTSDK\src\wsjtx.

If you have used “package”, install the .exe file as you would if downloaded from Joe’s site.

If you have used “rinstall” the wsjtx that runs will be in this directory:
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Compiling – more information
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From time to time:

Start a Maintenance Terminal: Start > Programs > JTSDK > Tools > JTSDK Maintenance then type: update upgrade

To build WSJT10, use.. build-wsjt package



Document revisions and references
Please check here for any updated version of this document:     
http://www.sucklingfamily.free-online.co.uk/WSJT10toX.pdf

References:
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http://www.sucklingfamily.free-online.co.uk/Doppler%20Tests%202%20June%202015.pdf

http://www.sucklingfamily.free-online.co.uk/Doppler%20Tests%2023%20May%202015.pdf


